BSDPORTAL.RU

На этом сайте обсуждаются вопросы использования ОС FreeBSD
 Портал  •  Статьи  •  Форум  •  Wiki  •  Поиск  •  FAQ  •  Обои  •   Официальная документация  •  Новые темы 

Часовой пояс: UTC + 4 часа




Начать новую тему Ответить на тему  [ Сообщений: 26 ]  На страницу Пред.  1, 2
Автор Сообщение
 Заголовок сообщения: Re: Нет звука
СообщениеДобавлено: Пн 07 ноя, 2016 6:06 pm 
Не в сети

Зарегистрирован: Вт 18 сен, 2007 10:26 am
Сообщения: 810
Откуда: СССР, Красноярск
Дружище, а в других ОС звук есть?


Вернуться к началу
 Профиль  
 
 Заголовок сообщения: Re: Нет звука
СообщениеДобавлено: Пн 07 ноя, 2016 9:15 pm 
Не в сети

Зарегистрирован: Вс 06 ноя, 2016 12:19 pm
Сообщения: 13
AlexVPetrov писал(а):
Если переключить
sysctl hw.snd.default_unit=2
Должно через HDMI выводить.

С HDMI тоже самое. На других ОС работает.

Попробовал произвести сборку ядра без встроенных модулей на звуковую карту, и подключил OSS. Звук появился но не переключает наушники с колонок и наоборот, играет там и там одновременно.

#cat /dev/sndstat
Код:
OSS 4.2 (b 2011/201611030739)BSD (C) 4Front Technologies 1996-2011
Kernel: FreeBSD 11.0-RELEASE-p3 #2 r308347M: Mon Nov  7 15:24:03 SAMT 2016
    alexmlw@notebook:/usr/obj/usr/src/sys/MYGENERIC


Audio devices:
0: HD Audio play pcm1 (OUTPUT)
   Engine 1 opened OUT by VMIX/0 @ 48000/48000 Hz Fragment: 1024/192000 (5.3 msec)
   Engine 2 opened OUT by clementine-play/1276 @ 48000/48000 Hz Fragment: 2048/192000 (10.6 msec)
1: HD Audio play pcm2 (OUTPUT)
2: HD Audio play spdifout (OUTPUT)
3: HD Audio rec select1 (INPUT)
   Opened IN by VMIX_IN/0 @ 48000/48000 Hz Fragment: 1024/192000 (5.3 msec)
4: HD Audio rec select2 (INPUT)

MIDI devices:

Mixers:
0: High Definition Audio 0x111d7695


NOTICE! Device numbers shown above may be wrong.
        Use the ossinfo command to find out the correct device names.


# ossmix
Код:
Selected mixer 0/High Definition Audio 0x111d7695
Known controls are:
codec1.jack.green.mode <pcm1|pcm2> (currently pcm1)
codec1.jack.pink [<leftvol>:<rightvol>] (currently 29.9:29.9 dB)
codec1.jack.int-speaker.mode <pcm1|pcm2> (currently pcm1)
codec1.jack.int-mic [<leftvol>:<rightvol>] (currently 29.9:29.9 dB)
codec1.record.select1.select11 [<leftvol>:<rightvol>] (currently 37.9:37.9 dB)
codec1.record.select1.select12 <select3|pcm1|pcm2|int-mic> (currently select3)
codec1.record.select2.select21 [<leftvol>:<rightvol>] (currently 37.9:37.9 dB)
codec1.record.select2.select22 <select3|pcm1|pcm2|int-mic> (currently select3)
codec1.misc.pcm1 [<leftvol>:<rightvol>] (currently 76.4:76.4 dB)
codec1.misc.pcm2 [<leftvol>:<rightvol>] (currently 76.4:76.4 dB)
codec1.misc <-28.-8dB|-19.-2dB|-9.-6dB|0.0dB|mute> (currently -19.-2dB)
codec4.jack.int-digout.mute ON|OFF (currently OFF)
vmix0-enable ON|OFF (currently ON)
vmix0-rate <decimal value> (currently 48000) (Read-only)
vmix0-channels <Stereo|Multich> (currently Stereo)
vmix0-src <High|OFF> (currently Fast)
vmix0-outvol <monovol> (currently 24.7 dB)
vmix0-invol <monovol> (currently 25.0 dB)
vmix0.pcm5 [<leftvol>:<rightvol>] (currently 25.0:25.0 dB)
vmix0.pcm6 [<leftvol>:<rightvol>] (currently 25.0:25.0 dB)
vmix0.pcm7 [<leftvol>:<rightvol>] (currently 25.0:25.0 dB)
vmix0.pcm8 [<leftvol>:<rightvol>] (currently 25.0:25.0 dB)


Буду пробовать штатный драйвер запускать дальше.


Вернуться к началу
 Профиль  
 
 Заголовок сообщения: Re: Нет звука
СообщениеДобавлено: Пн 07 ноя, 2016 10:39 pm 
Не в сети

Зарегистрирован: Вт 18 сен, 2007 10:26 am
Сообщения: 810
Откуда: СССР, Красноярск
Под OSS из портов есть ещё такие вещи:
virtual_oss-1.1.2 Virtual OSS multi-device mixer application
virtual_oss_ctl-1.1.0 Grapical control panel for the virtual OSS daemon


Вернуться к началу
 Профиль  
 
 Заголовок сообщения: Re: Нет звука
СообщениеДобавлено: Вт 08 ноя, 2016 12:29 am 
Не в сети

Зарегистрирован: Пт 03 сен, 2004 1:26 pm
Сообщения: 2149
alexmlw писал(а):
ankor писал(а):
sysctl hw.snd.default_unit=1

Видео и музыка пошла, но без звука.


Код:
% cat /dev/sndstat
Installed devices:
pcm0: <IDT (0x7695) (Analog 2.0+HP/2.0)> (play/rec) default
pcm1: <IDT (0x7695) (Right Analog Mic)> (rec)
pcm2: <Intel Panther Point (HDMI/DP 8ch)> (play)
No devices installed from userspace.


ну и куда Вы переключили?
Расшифровываем верхнее:
pcm0: <IDT (0x7695) (Analog 2.0+HP/2.0)> (play/rec) default
- аналоговый звук , playback + record

pcm1: <IDT (0x7695) (Right Analog Mic)> (rec)
- аналоговый микрофон, только record

pcm2: <Intel Panther Point (HDMI/DP 8ch)> (play)
- цифра HDMI 8'и канальный, playback

теперь скажите, что может быть если выставить sysctl hw.snd.default_unit=1
- те (то есть) сделать default'ым микрофон? и ждать что это устройство (record) будет
выполнять воспроизведение (playback)?

Есть "нестандартные" HDA sound карты, если я правильно понял, то звук у Вас включается
нажатием спец.клавиш (или переключается).

Проблема в ассоциациях nids, бывают случаи, когда даже pindump не помогает
с правильно комбинированными nids/as:
- простой пример, на одном и том же компьютере, после soft reboot из M$ в FreeBSD/Linux,
sound прекращал работать, точнее, все работало, звука не было - полная тишина, не помню удалось
ли с помощью alsamixer оживить в Linux, вроде да, но дебажить не стал, плюнул.

Так вот верхнее лечилось только выключением питания вместо soft-reboot.

Помню удалил драйвер производителя, поднял драйвер самого M$, скачал у M$ программу
показывающую ассоциации, и пытался что-то сообразить, в итоге, после soft-reboot,
звук был и в FreeBSD/Linux и в M$, но родной драйвер M$ был ужасно кривой, шипение, шумы...
А в FreeBSD/Linux - все качествено. Плюнул, вернул родной драйвер в M$, лечу выключением.
Не стал бороться...

OSS как вариант, если работает.

ps. Если у Вас speaker и sound переключаются одной спец.клавишей - нужно смотреть
pindump при загрузке со speaker=on и при загрузке с sound=on

pps. Лучше спрашивать у Мотина в списках рассылки freebsd, на персональные письма он отвечать
не будет.


Вернуться к началу
 Профиль  
 
 Заголовок сообщения: Re: Нет звука
СообщениеДобавлено: Вт 08 ноя, 2016 5:15 pm 
Не в сети

Зарегистрирован: Вс 06 ноя, 2016 12:19 pm
Сообщения: 13
lavr писал(а):
alexmlw писал(а):
ankor писал(а):
sysctl hw.snd.default_unit=1

Видео и музыка пошла, но без звука.


ну и куда Вы переключили?

Звук не ожидался, но и что мультимедиа пойдет тоже не ожидалось.

Если перейти в консоль, пойти под пользователем и нажать вниз или таб будет слышен писк как на спикере. Подгрузив speaker появляется устройство /dev/speaker, посылаю ему echo "aaaaaa" > /dev/speaker слышу 3 коротких звука. Похоже придется где-то что-то сломать :wall:


Вернуться к началу
 Профиль  
 
 Заголовок сообщения: Re: Нет звука
СообщениеДобавлено: Вс 13 ноя, 2016 10:55 am 
Не в сети

Зарегистрирован: Вс 06 ноя, 2016 12:19 pm
Сообщения: 13
Если модуль speaker не подключен и устройства /dev/speaker нету. Как тогда отключить звук спикера?


Вернуться к началу
 Профиль  
 
Показать сообщения за:  Поле сортировки  
Начать новую тему Ответить на тему  [ Сообщений: 26 ]  На страницу Пред.  1, 2

Часовой пояс: UTC + 4 часа


Кто сейчас на конференции

Зарегистрированные пользователи: Bing [Bot], Google [Bot], Yahoo [Bot]


Вы не можете начинать темы
Вы не можете отвечать на сообщения
Вы не можете редактировать свои сообщения
Вы не можете удалять свои сообщения
Вы не можете добавлять вложения

Найти:
Создано на основе phpBB® Forum Software © phpBB Group
Русская поддержка phpBB
Яндекс.Метрика