BSDPORTAL.RU

На этом сайте обсуждаются вопросы использования ОС FreeBSD
 Портал  •  Статьи  •  Форум  •  Wiki  •  Поиск  •  FAQ  •  Обои  •   Официальная документация  •  Новые темы 

Часовой пояс: UTC + 4 часа




Начать новую тему Ответить на тему  [ Сообщений: 31 ]  На страницу 1, 2  След.
Автор Сообщение
 Заголовок сообщения: KDE GNOMe проблемы с отрисовкой окон
СообщениеДобавлено: Ср 10 авг, 2016 6:51 am 
Не в сети

Зарегистрирован: Вт 09 авг, 2016 1:14 pm
Сообщения: 16
Откуда: НСО Сузун
Доброго времени суток. Наверняка вопрос не нов. Но к сожалению ничего найти чтото не получилось. Собственно дистрибутив FreeBSD 10.3 давольно таки не плохое железо. Проблема в следующем у меня лагают (медлено отрисовываются) окна. Понимаю что косяк скорее всего с видеоадаптером но как поправить не знаю. Зарание спасибо за помощь. Какие логи нужны пишите всё скину.


Вернуться к началу
 Профиль  
 
СообщениеДобавлено: Ср 10 авг, 2016 11:28 am 
Не в сети
Модератор
Аватара пользователя

Зарегистрирован: Ср 08 ноя, 2006 2:53 pm
Сообщения: 5304
Откуда: СССР, Харьков
arhe писал(а):
Собственно дистрибутив FreeBSD 10.3 давольно таки не плохое железо.

Очень исчерпывающая информация.
В КДЕ можно выключить "эффекты рабочего стола" пошустрее будет немного.


Вернуться к началу
 Профиль  
 
СообщениеДобавлено: Ср 10 авг, 2016 12:24 pm 
Не в сети

Зарегистрирован: Вт 09 авг, 2016 1:14 pm
Сообщения: 16
Откуда: НСО Сузун
железо
Processor Information
Socket Designation: LGA1155
Type: Central Processor
Family: Core i5
Manufacturer: Intel
ID: A9 06 03 00 FF FB EB BF
Signature: Type 0, Family 6, Model 58, Stepping 9
Version: Intel(R) Core(TM) i5-3570 CPU @ 3.40GHz
Voltage: 1.0 V
External Clock: 100 MHz
Max Speed: 3800 MHz
Current Speed: 3400 MHz
Status: Populated, Enabled
Upgrade: Other
L1 Cache Handle: 0x0005
L2 Cache Handle: 0x0006
L3 Cache Handle: 0x0007
Serial Number: To Be Filled By O.E.M.
Asset Tag: To Be Filled By O.E.M.
Part Number: To Be Filled By O.E.M.
Core Count: 4
Core Enabled: 1
Characteristics:
64-bit capable
ОЗУ 16G
Видео карта GeForce 210

Мне кажется что для отрисовки простейших перемещений окон и прокрутки ленты в браузере должно этого хватать. Эфекты вроде и так выключены.


Вернуться к началу
 Профиль  
 
СообщениеДобавлено: Ср 10 авг, 2016 12:39 pm 
Не в сети

Зарегистрирован: Вт 09 авг, 2016 1:14 pm
Сообщения: 16
Откуда: НСО Сузун
Нашел один нюанс. Всё перестаёт тормозить если не использовать openGl. Я так понимаю необходимо настроить драйвер под корректную работу openGl?


Вернуться к началу
 Профиль  
 
СообщениеДобавлено: Ср 10 авг, 2016 12:58 pm 
Не в сети
Модератор
Аватара пользователя

Зарегистрирован: Ср 08 ноя, 2006 2:53 pm
Сообщения: 5304
Откуда: СССР, Харьков
Так понял у вас nvidia в работе.
Покажите вывод :
pkg info | grep video
pkg info | grep nvidia
и что в /etc/X11/xorg.conf
У меня GF 7600 GS , OpenGL 2.0 драйвер nvidia-driver-304-304.131 и никаких тормозов.


Вернуться к началу
 Профиль  
 
СообщениеДобавлено: Ср 10 авг, 2016 1:23 pm 
Не в сети

Зарегистрирован: Вт 09 авг, 2016 1:14 pm
Сообщения: 16
Откуда: НСО Сузун
video
farstream-0.2.7 Collection of GStreamer modules and libraries for videoconferencing
ffmpeg-2.8.7_1,1 Realtime audio/video encoder/converter and streaming server
kdemultimedia-ffmpegthumbs-4.14.3 FFmpeg-based thumbnail generator for video files
libmpeg2-0.5.1_6 Free library for decoding MPEG-2 and MPEG-1 video streams
libtheora-1.1.1_6 Theora video codec for the Ogg multimedia streaming system
videoproto-2.3.2 Video extension headers
xf86-video-ati-7.5.0_3 X.Org ati display driver
xf86-video-intel-2.21.15_9 Driver for Intel integrated graphics chipsets
xf86-video-mach64-6.9.5 X.Org mach64 display driver
xf86-video-nv-2.1.20_7 X.Org nv display driver
xf86-video-openchrome-0.3.3_6 X.Org openChrome display driver
xf86-video-r128-6.10.0 X.Org r128 display driver
xf86-video-vesa-2.3.4 X.Org vesa display driver

nvidia
nvidia-driver-346.96 NVidia graphics card binary drivers for hardware OpenGL rendering
nvidia-xconfig-355.11 Tool to manipulate X configuration files for the NVidia driver

/etc/X11/xorg.conf у меня почемуто пустой :(


Вернуться к началу
 Профиль  
 
СообщениеДобавлено: Ср 10 авг, 2016 1:30 pm 
Не в сети

Зарегистрирован: Вт 18 сен, 2007 10:26 am
Сообщения: 814
Откуда: СССР, Красноярск
kern.maxfiles сколько установлено?
При установке KDE какой-то пакет говорит, что нужно установить
kern.maxfiles=25000
в /boot/loader.conf


Вернуться к началу
 Профиль  
 
СообщениеДобавлено: Ср 10 авг, 2016 1:36 pm 
Не в сети
Модератор
Аватара пользователя

Зарегистрирован: Ср 08 ноя, 2006 2:53 pm
Сообщения: 5304
Откуда: СССР, Харьков
arhe писал(а):
/etc/X11/xorg.conf у меня почемуто пустой :(

Запустите в консоле от рута nvidia-xconfig и будет вам xorg.conf
Перестартовать КДЕ или перегрузить машину.

AlexVPetrov писал(а):
kern.maxfiles сколько установлено?
При установке KDE какой-то пакет говорит, что нужно установить
kern.maxfiles=25000
в /boot/loader.conf

У меня по умолчанию
Код:
root@ankor:/home/ankor # sysctl kern.maxfiles
kern.maxfiles: 64231

Обычно машина в консоль пишет если мало.


Вернуться к началу
 Профиль  
 
СообщениеДобавлено: Ср 10 авг, 2016 1:39 pm 
Не в сети

Зарегистрирован: Вт 18 сен, 2007 10:26 am
Сообщения: 814
Откуда: СССР, Красноярск
arhe писал(а):
/etc/X11/xorg.conf у меня почемуто пустой :(

Тогда будет работать драйвер "nv" в котором с openGL плохо, а не "nvidia"


Вернуться к началу
 Профиль  
 
СообщениеДобавлено: Чт 11 авг, 2016 7:40 am 
Не в сети

Зарегистрирован: Вт 09 авг, 2016 1:14 pm
Сообщения: 16
Откуда: НСО Сузун
ankor писал(а):
Запустите в консоле от рута nvidia-xconfig и будет вам xorg.conf
Перестартовать КДЕ или перегрузить машину.

после этого Иксы не запустились
Код:
:X server died during startup
:X server for display :0 cannot be started, session disabled


Вернуться к началу
 Профиль  
 
СообщениеДобавлено: Чт 11 авг, 2016 8:03 am 
Не в сети

Зарегистрирован: Вт 18 сен, 2007 10:26 am
Сообщения: 814
Откуда: СССР, Красноярск
см. лог Xorg в /var/log/ на предмет ошибок.


Вернуться к началу
 Профиль  
 
СообщениеДобавлено: Чт 11 авг, 2016 9:21 am 
Не в сети

Зарегистрирован: Вт 09 авг, 2016 1:14 pm
Сообщения: 16
Откуда: НСО Сузун
Код:
[  2351.480] (EE) No devices detected.
[  2351.480] (EE)
Fatal server error:
[  2351.480] (EE) no screens found(EE)
[  2351.480] (EE)
Please consult the The X.Org Foundation support
    at http://wiki.x.org
 for help.
[  2351.480] (EE) Please also check the log file at "/var/log/Xorg.1.log" for additional information.
[  2351.480] (EE)
[  2351.490] (EE) Server terminated with error (1). Closing log file.


Вернуться к началу
 Профиль  
 
СообщениеДобавлено: Чт 11 авг, 2016 9:38 am 
Не в сети

Зарегистрирован: Вт 18 сен, 2007 10:26 am
Сообщения: 814
Откуда: СССР, Красноярск
А драйвер какой приняло?


Вернуться к началу
 Профиль  
 
СообщениеДобавлено: Чт 11 авг, 2016 10:59 am 
Не в сети

Зарегистрирован: Вт 09 авг, 2016 1:14 pm
Сообщения: 16
Откуда: НСО Сузун
Код:
[  2351.480] (WW) NVIDIA(0): The NVIDIA GeForce 210 GPU installed in this system is
[  2351.480] (WW) NVIDIA(0):     supported through the NVIDIA 340.xx Legacy drivers. Please
[  2351.480] (WW) NVIDIA(0):     visit http://www.nvidia.com/object/unix.html for more
[  2351.480] (WW) NVIDIA(0):     information.  The 346.96 NVIDIA driver will ignore this
[  2351.480] (WW) NVIDIA(0):     GPU.  Continuing probe...

Видимо как то так.


Вернуться к началу
 Профиль  
 
СообщениеДобавлено: Чт 11 авг, 2016 11:07 am 
Не в сети

Зарегистрирован: Вт 18 сен, 2007 10:26 am
Сообщения: 814
Откуда: СССР, Красноярск
А драйвер какой стоит?
для GeForce 210 нужен x11/nvidia-driver-340


Вернуться к началу
 Профиль  
 
СообщениеДобавлено: Чт 11 авг, 2016 11:29 am 
Не в сети

Зарегистрирован: Вт 09 авг, 2016 1:14 pm
Сообщения: 16
Откуда: НСО Сузун
видимо такой
[ 2351.304] (II) NVIDIA GLX Module 346.96 Sun Aug 23 21:29:48 PDT 2015


Вернуться к началу
 Профиль  
 
СообщениеДобавлено: Чт 11 авг, 2016 11:32 am 
Не в сети

Зарегистрирован: Вт 09 авг, 2016 1:14 pm
Сообщения: 16
Откуда: НСО Сузун
я переустановил драйвер на 340 и запустил nvidia-xconfig ребутнулся, кеды запустились но openGl не запускается.


Вернуться к началу
 Профиль  
 
СообщениеДобавлено: Чт 11 авг, 2016 11:48 am 
Не в сети

Зарегистрирован: Вт 18 сен, 2007 10:26 am
Сообщения: 814
Откуда: СССР, Красноярск
см. лог Xorg.


Вернуться к началу
 Профиль  
 
СообщениеДобавлено: Чт 11 авг, 2016 12:00 pm 
Не в сети

Зарегистрирован: Вт 09 авг, 2016 1:14 pm
Сообщения: 16
Откуда: НСО Сузун
[ 19.124]
X.Org X Server 1.17.4
Release Date: 2015-10-28
[ 19.124] X Protocol Version 11, Revision 0
[ 19.124] Build Operating System: FreeBSD 10.1-RELEASE-p37 amd64
[ 19.124] Current Operating System: FreeBSD server 10.3-RELEASE FreeBSD 10.3-RELEASE #0 r297264: Fri Mar 25 02:10:02 UTC 2016 root@releng1.nyi.freebsd.org:/usr/obj/usr/src/sys/GENERIC amd64
[ 19.124] Build Date: 28 July 2016 06:10:58AM
[ 19.124]
[ 19.124] Current version of pixman: 0.34.0
[ 19.124] Before reporting problems, check http://wiki.x.org
to make sure that you have the latest version.
[ 19.124] Markers: (--) probed, (**) from config file, (==) default setting,
(++) from command line, (!!) notice, (II) informational,
(WW) warning, (EE) error, (NI) not implemented, (??) unknown.
[ 19.124] (==) Log file: "/var/log/Xorg.0.log", Time: Thu Aug 11 14:18:06 2016
[ 19.210] (==) Using config file: "/etc/X11/xorg.conf"
[ 19.229] (==) ServerLayout "Layout0"
[ 19.229] (**) |-->Screen "Screen0" (0)
[ 19.229] (**) | |-->Monitor "Monitor0"
[ 19.244] (**) | |-->Device "Device0"
[ 19.244] (**) |-->Input Device "Keyboard0"
[ 19.244] (**) |-->Input Device "Mouse0"
[ 19.244] (==) Automatically adding devices
[ 19.244] (==) Automatically enabling devices
[ 19.244] (==) Not automatically adding GPU devices
[ 19.304] (==) FontPath set to:
/usr/local/share/fonts/misc/,
/usr/local/share/fonts/TTF/,
/usr/local/share/fonts/OTF/,
/usr/local/share/fonts/Type1/,
/usr/local/share/fonts/100dpi/,
/usr/local/share/fonts/75dpi/
[ 19.304] (==) ModulePath set to "/usr/local/lib/xorg/modules"
[ 19.304] (WW) Hotplugging is on, devices using drivers 'kbd', 'mouse' or 'vmmouse' will be disabled.
[ 19.304] (WW) Disabling Keyboard0
[ 19.304] (WW) Disabling Mouse0
[ 19.304] (II) Loader magic: 0x801510
[ 19.304] (II) Module ABI versions:
[ 19.304] X.Org ANSI C Emulation: 0.4
[ 19.304] X.Org Video Driver: 19.0
[ 19.304] X.Org XInput driver : 21.0
[ 19.304] X.Org Server Extension : 9.0
[ 19.318] (--) PCI:*(0:1:0:0) 10de:0a65:1043:847f rev 162, Mem @ 0xf6000000/16777216, 0xe0000000/268435456, 0xf0000000/33554432, I/O @ 0x0000e000/128, BIOS @ 0x????????/65536
[ 19.318] (II) LoadModule: "glx"
[ 19.342] (II) Loading /usr/local/lib/xorg/modules/extensions/libglx.so
[ 20.023] (II) Module glx: vendor="NVIDIA Corporation"
[ 20.023] compiled for 4.0.2, module version = 1.0.0
[ 20.023] Module class: X.Org Server Extension
[ 20.023] (II) NVIDIA GLX Module 340.93 Wed Aug 19 16:20:38 PDT 2015
[ 20.031] (II) LoadModule: "nvidia"
[ 20.031] (II) Loading /usr/local/lib/xorg/modules/drivers/nvidia_drv.so
[ 20.072] (II) Module nvidia: vendor="NVIDIA Corporation"
[ 20.072] compiled for 4.0.2, module version = 1.0.0
[ 20.072] Module class: X.Org Video Driver
[ 20.073] (II) NVIDIA dlloader X Driver 340.93 Wed Aug 19 16:00:14 PDT 2015
[ 20.073] (II) NVIDIA Unified Driver for all Supported NVIDIA GPUs
[ 20.073] (--) Using syscons driver with X support (version 134217730.0)
[ 20.073] (--) using VT number 9

[ 20.082] (II) Loading sub module "fb"
[ 20.082] (II) LoadModule: "fb"
[ 20.082] (II) Loading /usr/local/lib/xorg/modules/libfb.so
[ 20.089] (II) Module fb: vendor="X.Org Foundation"
[ 20.089] compiled for 1.17.4, module version = 1.0.0
[ 20.089] ABI class: X.Org ANSI C Emulation, version 0.4
[ 20.089] (WW) Unresolved symbol: fbGetGCPrivateKey
[ 20.089] (II) Loading sub module "wfb"
[ 20.089] (II) LoadModule: "wfb"
[ 20.089] (II) Loading /usr/local/lib/xorg/modules/libwfb.so
[ 20.094] (II) Module wfb: vendor="X.Org Foundation"
[ 20.094] compiled for 1.17.4, module version = 1.0.0
[ 20.094] ABI class: X.Org ANSI C Emulation, version 0.4
[ 20.094] (II) Loading sub module "ramdac"
[ 20.094] (II) LoadModule: "ramdac"
[ 20.094] (II) Module "ramdac" already built-in
[ 20.108] (WW) VGA arbiter: cannot open kernel arbiter, no multi-card support
[ 20.108] (**) NVIDIA(0): Depth 24, (--) framebuffer bpp 32
[ 20.108] (==) NVIDIA(0): RGB weight 888
[ 20.108] (==) NVIDIA(0): Default visual is TrueColor
[ 20.108] (==) NVIDIA(0): Using gamma correction (1.0, 1.0, 1.0)
[ 20.109] (**) NVIDIA(0): Enabling 2D acceleration
[ 20.687] (II) NVIDIA(0): NVIDIA GPU GeForce 210 (GT218) at PCI:1:0:0 (GPU-0)
[ 20.687] (--) NVIDIA(0): Memory: 1048576 kBytes
[ 20.687] (--) NVIDIA(0): VideoBIOS: 70.18.5f.00.06
[ 20.687] (II) NVIDIA(0): Detected PCI Express Link width: 16X
[ 20.688] (--) NVIDIA(0): Valid display device(s) on GeForce 210 at PCI:1:0:0
[ 20.688] (--) NVIDIA(0): CRT-0
[ 20.688] (--) NVIDIA(0): DELL E170S (CRT-1) (boot, connected)
[ 20.688] (--) NVIDIA(0): DFP-0
[ 20.689] (--) NVIDIA(0): DFP-1
[ 20.689] (--) NVIDIA(GPU-0): CRT-0: 400.0 MHz maximum pixel clock
[ 20.689] (--) NVIDIA(GPU-0): DELL E170S (CRT-1): 400.0 MHz maximum pixel clock
[ 20.689] (--) NVIDIA(0): DFP-0: Internal TMDS
[ 20.689] (--) NVIDIA(GPU-0): DFP-0: 330.0 MHz maximum pixel clock
[ 20.689] (--) NVIDIA(0): DFP-1: Internal TMDS
[ 20.689] (--) NVIDIA(GPU-0): DFP-1: 165.0 MHz maximum pixel clock
[ 20.689] (**) NVIDIA(0): Using HorizSync/VertRefresh ranges from the EDID for display
[ 20.689] (**) NVIDIA(0): device DELL E170S (CRT-1) (Using EDID frequencies has been
[ 20.689] (**) NVIDIA(0): enabled on all display devices.)
[ 20.689] (==) NVIDIA(0):
[ 20.689] (==) NVIDIA(0): No modes were requested; the default mode "nvidia-auto-select"
[ 20.689] (==) NVIDIA(0): will be used as the requested mode.
[ 20.689] (==) NVIDIA(0):
[ 20.690] (II) NVIDIA(0): Validated MetaModes:
[ 20.690] (II) NVIDIA(0): "CRT-1:nvidia-auto-select"
[ 20.690] (II) NVIDIA(0): Virtual screen size determined to be 1280 x 1024
[ 20.720] (--) NVIDIA(0): DPI set to (95, 96); computed from "UseEdidDpi" X config
[ 20.720] (--) NVIDIA(0): option
[ 20.720] (--) Depth 24 pixmap format is 32 bpp
[ 20.720] (II) NVIDIA: Reserving 768.00 MB of virtual memory for indirect memory
[ 20.720] (II) NVIDIA: access.
[ 20.723] (II) NVIDIA(0): Setting mode "CRT-1:nvidia-auto-select"
[ 20.799] (==) NVIDIA(0): Disabling shared memory pixmaps
[ 20.799] (==) NVIDIA(0): Backing store enabled
[ 20.799] (==) NVIDIA(0): Silken mouse enabled
[ 20.800] (**) NVIDIA(0): DPMS enabled
[ 20.800] (II) Loading sub module "dri2"
[ 20.800] (II) LoadModule: "dri2"
[ 20.800] (II) Module "dri2" already built-in
[ 20.800] (II) NVIDIA(0): [DRI2] Setup complete
[ 20.800] (II) NVIDIA(0): [DRI2] VDPAU driver: nvidia
[ 20.800] (--) RandR disabled
[ 20.810] (II) Initializing extension GLX
[ 20.810] (II) Indirect GLX disabled.(II) config/devd: probing input devices...
[ 21.161] (II) config/devd: adding input device (null) (/dev/kbdmux)
[ 21.161] (II) LoadModule: "kbd"
[ 21.175] (II) Loading /usr/local/lib/xorg/modules/input/kbd_drv.so
[ 21.185] (II) Module kbd: vendor="X.Org Foundation"
[ 21.185] compiled for 1.17.4, module version = 1.8.1
[ 21.185] Module class: X.Org XInput Driver
[ 21.185] ABI class: X.Org XInput driver, version 21.0
[ 21.185] (II) Using input driver 'kbd' for 'kbdmux'
[ 21.185] (**) kbdmux: always reports core events
[ 21.185] (**) kbdmux: always reports core events
[ 21.185] (**) Option "Protocol" "standard"
[ 21.185] (**) Option "XkbRules" "base"
[ 21.185] (**) Option "XkbModel" "pc105"
[ 21.185] (**) Option "XkbLayout" "us"
[ 21.185] (**) Option "config_info" "devd:kbdmux"
[ 21.185] (II) XINPUT: Adding extended input device "kbdmux" (type: KEYBOARD, id 6)
[ 21.198] (II) config/devd: kbdmux is enabled, ignoring device atkbd0
[ 21.198] (II) config/devd: adding input device (null) (/dev/sysmouse)
[ 21.198] (II) LoadModule: "mouse"
[ 21.199] (II) Loading /usr/local/lib/xorg/modules/input/mouse_drv.so
[ 21.216] (II) Module mouse: vendor="X.Org Foundation"
[ 21.216] compiled for 1.17.4, module version = 1.9.1
[ 21.216] Module class: X.Org XInput Driver
[ 21.216] ABI class: X.Org XInput driver, version 21.0
[ 21.216] (II) Using input driver 'mouse' for 'sysmouse'
[ 21.216] (**) sysmouse: always reports core events
[ 21.216] (**) Option "Device" "/dev/sysmouse"
[ 21.216] (==) sysmouse: Protocol: "Auto"
[ 21.216] (**) sysmouse: always reports core events
[ 21.216] (==) sysmouse: Emulate3Buttons, Emulate3Timeout: 50
[ 21.216] (**) sysmouse: ZAxisMapping: buttons 4 and 5
[ 21.216] (**) sysmouse: Buttons: 5
[ 21.216] (**) Option "config_info" "devd:sysmouse"
[ 21.216] (II) XINPUT: Adding extended input device "sysmouse" (type: MOUSE, id 7)
[ 21.216] (**) sysmouse: (accel) keeping acceleration scheme 1
[ 21.216] (**) sysmouse: (accel) acceleration profile 0
[ 21.216] (**) sysmouse: (accel) acceleration factor: 2.000
[ 21.216] (**) sysmouse: (accel) acceleration threshold: 4
[ 21.216] (II) sysmouse: SetupAuto: hw.iftype is 4, hw.model is 0
[ 21.216] (II) sysmouse: SetupAuto: protocol is SysMouse
[ 21.216] (II) config/devd: device /dev/ums0 already opened

Ошибок то вроде нет. А что и где тогда искать не догоняю =(


Вернуться к началу
 Профиль  
 
СообщениеДобавлено: Чт 11 авг, 2016 12:28 pm 
Не в сети

Зарегистрирован: Вт 18 сен, 2007 10:26 am
Сообщения: 814
Откуда: СССР, Красноярск
А с чего решили что "openGl не запускается"?
P.S. а в /et/rc/conf есть такое?:
dbus_enable="YES"
hald_enable="YES"
polkitd_enable="YES"


Вернуться к началу
 Профиль  
 
Показать сообщения за:  Поле сортировки  
Начать новую тему Ответить на тему  [ Сообщений: 31 ]  На страницу 1, 2  След.

Часовой пояс: UTC + 4 часа


Кто сейчас на конференции

Зарегистрированные пользователи: Bing [Bot], Google [Bot]


Вы не можете начинать темы
Вы не можете отвечать на сообщения
Вы не можете редактировать свои сообщения
Вы не можете удалять свои сообщения
Вы не можете добавлять вложения

Найти:
Создано на основе phpBB® Forum Software © phpBB Group
Русская поддержка phpBB
Яндекс.Метрика