BSDPORTAL.RU

На этом сайте обсуждаются вопросы использования ОС FreeBSD
 Портал  •  Статьи  •  Форум  •  Wiki  •  Поиск  •  FAQ  •  Обои  •   Официальная документация  •  Новые темы 

Часовой пояс: UTC + 4 часа




Начать новую тему Ответить на тему  [ Сообщений: 6 ] 
Автор Сообщение
СообщениеДобавлено: Чт 05 янв, 2017 4:48 am 
Не в сети

Зарегистрирован: Чт 05 янв, 2017 4:29 am
Сообщения: 2
Привет. Поставил FreeBSD. В ноутбуке две видеокарты, radeon и intel. Если поставить в BIOS дискретную radeon как основную видеокарту, то иксы работают с драйвером radeon. Если поставить intel, то с драйвером intel они не запускаются, только с медленным vesa. На линуксе работало.

Xorg.0.log
Код:
[   739.351]
X.Org X Server 1.17.4
Release Date: 2015-10-28
[   739.351] X Protocol Version 11, Revision 0
[   739.351] Build Operating System: FreeBSD 11.0-RELEASE-p6 i386
[   739.352] Current Operating System: FreeBSD freebsd 11.0-RELEASE-p1 FreeBSD 11.0-RELEASE-p1 #0 r306420: Thu Sep 29 03:40:55 UTC 2016     root@releng2.nyi.freebsd.org:/usr/obj/usr/src/sys/GENERIC i386
[   739.352] Build Date: 24 December 2016  06:44:35AM
[   739.352] 
[   739.352] Current version of pixman: 0.34.0
[   739.352]    Before reporting problems, check http://wiki.x.org
   to make sure that you have the latest version.
[   739.352] Markers: (--) probed, (**) from config file, (==) default setting,
   (++) from command line, (!!) notice, (II) informational,
   (WW) warning, (EE) error, (NI) not implemented, (??) unknown.
[   739.353] (==) Log file: "/var/log/Xorg.0.log", Time: Thu Jan  5 00:25:25 2017
[   739.354] (==) Using config directory: "/usr/local/etc/X11/xorg.conf.d"
[   739.354] (==) No Layout section.  Using the first Screen section.
[   739.355] (==) No screen section available. Using defaults.
[   739.355] (**) |-->Screen "Default Screen Section" (0)
[   739.355] (**) |   |-->Monitor "<default monitor>"
[   739.355] (==) No device specified for screen "Default Screen Section".
   Using the first device section listed.
[   739.355] (**) |   |-->Device "Card0"
[   739.355] (==) No monitor specified for screen "Default Screen Section".
   Using a default monitor configuration.
[   739.356] (==) Automatically adding devices
[   739.356] (==) Automatically enabling devices
[   739.356] (==) Not automatically adding GPU devices
[   739.356] (==) FontPath set to:
   /usr/local/share/fonts/misc/,
   /usr/local/share/fonts/TTF/,
   /usr/local/share/fonts/OTF/,
   /usr/local/share/fonts/Type1/,
   /usr/local/share/fonts/100dpi/,
   /usr/local/share/fonts/75dpi/
[   739.356] (==) ModulePath set to "/usr/local/lib/xorg/modules"
[   739.356] (II) The server relies on devd to provide the list of input devices.
   If no devices become available, reconfigure devd or disable AutoAddDevices.
[   739.357] (II) Loader magic: 0x8238ff0
[   739.357] (II) Module ABI versions:
[   739.357]    X.Org ANSI C Emulation: 0.4
[   739.357]    X.Org Video Driver: 19.0
[   739.357]    X.Org XInput driver : 21.0
[   739.357]    X.Org Server Extension : 9.0
[   739.357] (--) PCI:*(0:0:2:0) 8086:2a42:17aa:2112 rev 7, Mem @ 0xf4400000/4194304, 0xd0000000/268435456, I/O @ 0x00001800/8, BIOS @ 0x????????/65536
[   739.358] (--) PCI: (0:0:2:1) 8086:2a43:17aa:2112 rev 7, Mem @ 0xf4200000/1048576
[   739.358] (II) LoadModule: "glx"
[   739.359] (II) Loading /usr/local/lib/xorg/modules/extensions/libglx.so
[   739.363] (II) Module glx: vendor="X.Org Foundation"
[   739.363]    compiled for 1.17.4, module version = 1.0.0
[   739.363]    ABI class: X.Org Server Extension, version 9.0
[   739.363] (==) AIGLX enabled
[   739.364] (II) LoadModule: "intel"
[   739.365] (II) Loading /usr/local/lib/xorg/modules/drivers/intel_drv.so
[   739.366] (II) Module intel: vendor="X.Org Foundation"
[   739.366]    compiled for 1.17.4, module version = 2.21.15
[   739.366]    Module class: X.Org Video Driver
[   739.366]    ABI class: X.Org Video Driver, version 19.0
[   739.366] (II) intel: Driver for Intel(R) Integrated Graphics Chipsets:
   i810, i810-dc100, i810e, i815, i830M, 845G, 854, 852GM/855GM, 865G,
   915G, E7221 (i915), 915GM, 945G, 945GM, 945GME, Pineview GM,
   Pineview G, 965G, G35, 965Q, 946GZ, 965GM, 965GME/GLE, G33, Q35, Q33,
   GM45, 4 Series, G45/G43, Q45/Q43, G41, B43, HD Graphics,
   HD Graphics 2000, HD Graphics 3000, HD Graphics 2500,
   HD Graphics 4000, HD Graphics P4000, HD Graphics 4600,
   HD Graphics 5000, HD Graphics P4600/P4700, Iris(TM) Graphics 5100,
   HD Graphics 4400, HD Graphics 4200, Iris(TM) Pro Graphics 5200
[   739.372] (--) Using syscons driver with X support (version 2.0)
[   739.372] (--) using VT number 9

[   739.382] (EE) No devices detected.
[   739.382] (EE)
Fatal server error:
[   739.382] (EE) no screens found(EE)
[   739.382] (EE)
Please consult the The X.Org Foundation support
    at http://wiki.x.org
 for help.
[   739.383] (EE) Please also check the log file at "/var/log/Xorg.0.log" for additional information.
[   739.383] (EE)
[   739.397] (EE) Server terminated with error (1). Closing log file.

/usr/local/etc/X11/xorg.conf.d/driver-intel.conf
Код:
Section "Device"
    Identifier "Card0"
    Driver "intel"
EndSection


ниже loader.conf, от изменения i915_load или kern.vty ничего не меняется, хоть так хоть сяк не запускается.
/boot/loader.conf
Код:
aesni_load="YES"
geom_eli_load="YES"
kern.geom.label.disk_ident.enable="0"
kern.geom.label.gptid.enable="0"
zfs_load="YES"
acpi_ibm_load="YES"
cpufreq_load="YES"
i915_load="YES"
kern.vty=vt


При первой попытке старта иксов в dmesg появляется это:
Код:
info: [drm] Initialized drm 1.1.0 20060810
drmn0: <Mobile Intel\M-B\M-. GM45 Express Chipset> on vgapci0
error: [drm:pid762:drm_get_minor] *ERROR* Failed to create cdev: 17
device_attach: drmn0 attach returned -17


Есть идеи почему не работает?

X ставил через pkg. Я читал про WITH_NEW_XORG и WITH_KMS и пересборку через порты, но это было для 10 и более ранних версий, а как я понял, в FreeBSD 11 X уже в пакетах должен быть собран с WITH_NEW_XORG, теперь это по умолчанию, я ведь прав? Или я не прав и надо сносить и собирать из портов?


Вернуться к началу
 Профиль  
 
СообщениеДобавлено: Чт 05 янв, 2017 12:35 pm 
Не в сети
Модератор

Зарегистрирован: Сб 11 сен, 2004 6:33 am
Сообщения: 5025
Откуда: Москва
WITH_NEW_XORG и WITH_KMS точно никакие не нужны, эти настройки канули в Лету еще несколько лет назад


Вернуться к началу
 Профиль  
 
СообщениеДобавлено: Чт 05 янв, 2017 1:13 pm 
Не в сети

Зарегистрирован: Вс 05 июн, 2005 4:19 pm
Сообщения: 3066
Откуда: Ukraine
Фря не умеет некоторые Haswell-лы, а Broadwell-E, Skylake и новее - вообще не умеет.
https://wiki.freebsd.org/Graphics/

Процессор какой установлен?

_________________
Ми можемо все - що здатні собі уявити!
uname -a
Linux nonamehost 4.9.0-zen-fidaj+ #1 ZEN SMP PREEMPT Thu Dec 15 23:31:44 EET 2016 x86_64 x86_64 x86_64 GNU/Linux


Вернуться к началу
 Профиль  
 
СообщениеДобавлено: Чт 05 янв, 2017 1:21 pm 
Не в сети

Зарегистрирован: Вт 18 сен, 2007 10:26 am
Сообщения: 802
Откуда: СССР, Красноярск
У меня Asus N10j с двумя вручную переключаемыми картами.
Я создал 2 конфига для xorg и скриптом при старте проверяю какая карта в данный момент активна (парсинг dmesg)
и соответствующий конфиг копируется как рабочий.
После можно проверить запущен ли менеджер дисплеев (gdm, kdm, slim) и запустить его если не запущен.


Вернуться к началу
 Профиль  
 
СообщениеДобавлено: Чт 05 янв, 2017 1:41 pm 
Не в сети

Зарегистрирован: Пт 03 сен, 2004 1:26 pm
Сообщения: 2127
ch1p писал(а):
Привет. Поставил FreeBSD. В ноутбуке две видеокарты, radeon и intel. Если поставить в BIOS дискретную radeon как основную видеокарту, то иксы работают с драйвером radeon. Если поставить intel, то с драйвером intel они не запускаются, только с медленным vesa. На линуксе работало.


ThinkPad T400:

- Intel Graphics Media Accelerator 4500MHD
- Switchable Graphics with Intel GMA 4500MHD and ATI Mobility Radeon HD 3470 (256 MB)

оба видео, судя по kms в 11.0-R - должны поддерживаться.
Если переключение возможно в BIOS, можете попробовать оба драйвера
по очереди, перезагружаясь и меняя режим в BIOS:

для Intel GMA 4500M HD, /boot/loader.conf:

нижнее отличается от i915_load

#-- Intel KMS
i915kms_load="YES"

для Radeon HD 3470

#-- Radeon KMS
radeonkms_load="YES"

видеорежим выставляется одинаково, например:

kern.vt.fb.default_mode="1024x768"


Вернуться к началу
 Профиль  
 
СообщениеДобавлено: Чт 05 янв, 2017 4:18 pm 
Не в сети

Зарегистрирован: Чт 05 янв, 2017 4:29 am
Сообщения: 2
lavr писал(а):
i915kms_load="YES"
помогло, спасибо!


Вернуться к началу
 Профиль  
 
Показать сообщения за:  Поле сортировки  
Начать новую тему Ответить на тему  [ Сообщений: 6 ] 

Часовой пояс: UTC + 4 часа


Кто сейчас на конференции

Зарегистрированные пользователи: Bing [Bot], Google [Bot]


Вы не можете начинать темы
Вы не можете отвечать на сообщения
Вы не можете редактировать свои сообщения
Вы не можете удалять свои сообщения
Вы не можете добавлять вложения

Найти:
Создано на основе phpBB® Forum Software © phpBB Group
Русская поддержка phpBB
Яндекс.Метрика