BSDPORTAL.RU

На этом сайте обсуждаются вопросы использования ОС FreeBSD
 Портал  •  Статьи  •  Форум  •  Wiki  •  Поиск  •  FAQ  •  Обои  •   Официальная документация  •  Новые темы 

Часовой пояс: UTC + 4 часа




Начать новую тему Ответить на тему  [ Сообщений: 10 ] 
Автор Сообщение
СообщениеДобавлено: Ср 14 окт, 2015 1:40 pm 
Не в сети

Зарегистрирован: Чт 08 окт, 2015 5:36 pm
Сообщения: 9
Здравствуйте.

Проблема собственно выделена ниже. Прошу советов по решению.
Ставил cтандартно: pkg install munin-node && pkg install munin-master

Вопрос у меня - как это решить и избежать в дальнейшем таких проблем

root@gw2:/var/cron/tabs # uname -a
FreeBSD gw2 10.2-RELEASE-p3 FreeBSD 10.2-RELEASE-p3 #0: Thu Sep 17 20:57:19 NOVT 2015 root@gw2:/usr/obj/usr/src/sys/GW2 amd64
root@gw2:/var/cron/tabs #
root@gw2:/var/cron/tabs #
root@gw2:/var/cron/tabs # pkg audit
0 problem(s) in the installed packages found.
root@gw2:/var/cron/tabs #
root@gw2:/var/cron/tabs # /usr/local/bin/munin-cron
Can't load '/usr/local/lib/perl5/site_perl/mach/5.20/auto/RRDs/RRDs.so' for module RRDs: /usr/local/lib/libpng16.so.16: version PNG16_0 required by /usr/local/lib/librrd.so.4 not defined at /usr/local/lib/perl5/5.20/mach/DynaLoader.pm line 193.
at /usr/local/lib/perl5/site_perl/Munin/Master/UpdateWorker.pm line 19.
Compilation failed in require at /usr/local/lib/perl5/site_perl/Munin/Master/UpdateWorker.pm line 19.
BEGIN failed--compilation aborted at /usr/local/lib/perl5/site_perl/Munin/Master/UpdateWorker.pm line 19.
Compilation failed in require at /usr/local/lib/perl5/site_perl/Munin/Master/Update.pm line 17.
BEGIN failed--compilation aborted at /usr/local/lib/perl5/site_perl/Munin/Master/Update.pm line 17.
Compilation failed in require at /usr/local/share/munin/munin-update line 14.
BEGIN failed--compilation aborted at /usr/local/share/munin/munin-update line 14.


Вернуться к началу
 Профиль  
 
СообщениеДобавлено: Ср 14 окт, 2015 3:52 pm 
Не в сети
Модератор

Зарегистрирован: Сб 11 сен, 2004 6:33 am
Сообщения: 5110
Откуда: Москва
Только что проверил на свежей 10.2, никаких проблем нет. Все пакеты последних версий? Из одного репозитория? Затейте куда-нибудь objdump -x всех трёх библиотек.


Вернуться к началу
 Профиль  
 
СообщениеДобавлено: Ср 14 окт, 2015 5:06 pm 
Не в сети

Зарегистрирован: Чт 08 окт, 2015 5:36 pm
Сообщения: 9
Дико извиняюсь, я не настолько продвинут, чтоб эту команду знать - сделал непонятно-что вот так:

root@gw2:/tmp # objdump -x /usr/local/lib/perl5/site_perl/mach/5.20/auto/RRDs/RRDs.so >RRDs.so.objdump-x
root@gw2:/tmp # objdump -x /usr/local/lib/libpng16.so.16 > libpng16.so.16.objdump-x
root@gw2:/tmp # objdump -x /usr/local/lib/librrd.so.4 > librrd.so.4.objdump-x

не смейтесь сильно, если не сынтуитил

выложил здесь - https://drive.google.com/folderview?id= ... sp=sharing

Репозитарий я точно не менял, ставил все по умолчанию, pkg audit показывает что все ок.


Вернуться к началу
 Профиль  
 
СообщениеДобавлено: Ср 14 окт, 2015 5:53 pm 
Не в сети
Модератор

Зарегистрирован: Сб 11 сен, 2004 6:33 am
Сообщения: 5110
Откуда: Москва
Нужно не pkg audit, а pkg check -B
Покажите ещё pkg version и pkg info png.


Вернуться к началу
 Профиль  
 
СообщениеДобавлено: Чт 15 окт, 2015 8:17 am 
Не в сети

Зарегистрирован: Чт 08 окт, 2015 5:36 pm
Сообщения: 9
root@gw2:/tmp # pkg info png
png-1.6.17
Name : png
Version : 1.6.17
Installed on : Tue Sep 29 20:36:23 NOVT 2015
Origin : graphics/png
Architecture : freebsd:10:x86:64
Prefix : /usr/local
Categories : graphics
Licenses :
Maintainer : portmgr@FreeBSD.org
WWW : http://www.libpng.org/pub/png/libpng.html
Comment : Library for manipulating PNG images
Options :
APNG : on
PNGTEST : on
Shared Libs provided:
libpng16.so.16
Annotations :
cpe : cpe:2.3:a:libpng:libpng:1.6.17:::::freebsd10:x64
repo_type : binary
repository : FreeBSD
Flat size : 1017KiB
Description :
Libpng was written as a companion to the PNG specification, as a
way to reduce the amount of time and effort it takes to support
the PNG file format in application programs. Most users will not
have to modify the library significantly; advanced users may want
to modify it more. The library was coded for both users. All
attempts were made to make it as complete as possible, while
keeping the code easy to understand. Currently, this library
only supports C. Support for other languages is being considered.

LICENSE: libpng license

WWW: http://www.libpng.org/pub/png/libpng.html
http://libpng.sourceforge.net/


Вернуться к началу
 Профиль  
 
СообщениеДобавлено: Чт 15 окт, 2015 8:19 am 
Не в сети

Зарегистрирован: Чт 08 окт, 2015 5:36 pm
Сообщения: 9
pkg version
выложил
https://drive.google.com/open?id=0B6CvR ... nlSdjk3Sk0


Вернуться к началу
 Профиль  
 
СообщениеДобавлено: Чт 15 окт, 2015 8:23 am 
Не в сети

Зарегистрирован: Чт 08 окт, 2015 5:36 pm
Сообщения: 9
root@gw2:/tmp # pkg check -B
Checking all packages: 100%
root@gw2:/tmp #


Вернуться к началу
 Профиль  
 
СообщениеДобавлено: Чт 15 окт, 2015 10:58 am 
Не в сети
Модератор

Зарегистрирован: Сб 11 сен, 2004 6:33 am
Сообщения: 5110
Откуда: Москва
Я первым же делом спросил последних ли версий у вас пакеты. Обновляйте.


Вернуться к началу
 Профиль  
 
СообщениеДобавлено: Пт 16 окт, 2015 8:16 am 
Не в сети

Зарегистрирован: Чт 08 окт, 2015 5:36 pm
Сообщения: 9
ок, спасибо огромное, похоже в этом проблема и была.
помогло : portupgrade -ay

странно, я в bsd не гуру, и может чего-то не понимаю, до этого я делал:
portsnap fetch extract update
freebsd-update fetch install
pkg audit
и думал что у меня все в порядке с обновлениями, а оказалось, что нет.
А в связи с тем что я пересобирал ядро с поддержкой ALTQ может после обновления еще нужно что-то сделать?


Вернуться к началу
 Профиль  
 
СообщениеДобавлено: Пт 16 окт, 2015 1:05 pm 
Не в сети
Модератор

Зарегистрирован: Сб 11 сен, 2004 6:33 am
Сообщения: 5110
Откуда: Москва
Какой portupgrade, вы же munin из пакетов ставили? Используйте либо только порты, либо только пакеты, и поддерживайте в актуальном состоянии, больше ничего не нужно.


Вернуться к началу
 Профиль  
 
Показать сообщения за:  Поле сортировки  
Начать новую тему Ответить на тему  [ Сообщений: 10 ] 

Часовой пояс: UTC + 4 часа


Кто сейчас на конференции

Зарегистрированные пользователи: Bing [Bot], Google [Bot]


Вы не можете начинать темы
Вы не можете отвечать на сообщения
Вы не можете редактировать свои сообщения
Вы не можете удалять свои сообщения
Вы не можете добавлять вложения

Найти:
Создано на основе phpBB® Forum Software © phpBB Group
Русская поддержка phpBB
Яндекс.Метрика